Bugs
6mo ago

How to post a bug

  1. Explain what's not working in detail.

  2. Tell us what browser/desktop app/OS/runtime you're using.

  3. Include a screenshot, video, code snippet, or a .rev backup file.

0 replies
12h ago

State machine transition easings are not carried over...

...when copying and pasting an artboard across different projects.

Any custom easings get replaced by the standard linear interpolation.

0 replies
2d ago

Continued (endless) processing of the pasted asset.

1) I've copy-pasted a vector asset from the Adobe Illustrator, as I usually do (and did successfully before), but asset has not pasted but has been stack on "processing". Even I opened the project file next day, it still "processing"
2)Windows 11, last version of the desktop Rive.
3)

2 replies
J
3d ago

a very bad-as experience

I wanted to rename some layers so selecting the layers using my mouse button moved the artboard i have to click outside the artboard and then select again but press ctrl button to select layers, missed a layer? now press shift to select a layer and pressing ctrl removes selection, dont worry pressing Ctrl+z might restore selected layers but no repeat all again. Ok now i made a group and wanted to rename it. Guess what i cant rename the group. The most retarted menu opens with no option to rename. I tapped the hell out of my left click but no i was not able to rename any group. I added bones to my groups and i tried to copy the group with bones and guess what? only bones were copied. The hell im supposed to do with bones? I have used adobe photoshop, illustrator, figma, xd, but this is some next level experience. thumbs up for whoever was in charge of this.

2 replies
P
4d ago

Can't rename layers

I imported some svg assets from figma and now when i ry to rename layers by double clicking, nothing happens. Also, there should be an option to rename the layer and to group layers when you right click them.

In the video i'm double ckicking the layers but nothing happens.

Other files are still normal

1 reply
S
4d ago

Desktop app stays in loading mode

I've downloaded the desktop app for Windows but it stays forever in the loading screen, I've waited for half an hour but nothing happens. I've tried deinstalling but the same thing happens.

0 replies
S
6d ago

Rive file won't open after importing heavy Figma-made SVG file

Hey,

I have an urgent deadline with a client and I tried to add in a Figma-made SVG into my Rive file that has lots of compound paths/vector layers. Don't know how Figma made it such a big SVG file when I exported it from there (around 580KB) but now because it's in the Rive file it's made it impossible to open the file without it crashing.

I've tried opening it in the Desktop app, Chrome, Safari to no avail. I've created a new file to work from temporarily but I need access to this file ASAP.

If there's a way to just delete this heavy asset from this file or revert it back to a version where this asset didn't exist, I would really appreciate that. The file ID is 356718 - 801697.

I'm not even sure if file size is the issue but if it is, wish there was a warning modal when importing potentially large files that could prevent this in the future!

Thanks.

2 replies
7d ago

Issue with Stopping Audio Track in Nested Artboard

If I key a long audio track (like a song) in a Nested Artboard and press play in the parent artboard, the audio track starts playing. However, the issue is that the audio track doesn't stop when I stop the state machine, even when I close the file. The only way to stop the song is by closing the entire Rive tab or the Rive app.

0 replies
m
7d ago

follow path constraint not working

Since the follow path constraint itself does work alone,

but it crashes when page auto refresh or share project link activation.

the message "Rive had to patch your project since bad data" pops up after trying to share my project.

why does this happen?

i use both desktop app and website, also I use macOS

1 reply
E
8d ago

Heart has square around in community files:

https://rive.app/community/files/

0 replies
9d ago

Double-click Nested Artboard's area stops the State Machine

When I press play to test my project and double-click within a nested artboard area, it stops the state machine and takes me to the nested artboard's source.

1 reply
12d ago

Error on "Web (JS)" article quick start example

On this article

Error text:

TypeError
CanvasRenderingContext2D.clip: Argument 1 does not implement interface Path2D.
c@https://m7p872.csb.app/node_modules/
rive-app/canvas/rive.js:42:323
b@https://m7p872.csb.app/node_modules/
rive-app/canvas/rive.js:30:112
This screen is visible only in development. It will not appear if the app crashes in production.
Open your browser’s developer console to further inspect this error.
This error overlay is powered by `react-error-overlay` used in `create-react-app`.

Console error text: CanvasRenderingContext2D.clip: Argument 1 does not implement interface Path2D.

Dunno if you were aware of this already.

2 replies
12d ago

SVG import color bug

When copy-paste colored objects from Adobe Illustrator, everything turns black

3 replies
12d ago

File renaming bug

If the file name is too long, it does not scroll to the end with the cursor.

2 replies
P
12d ago

Zoom keys don‘t work on app for Mac

Hi, I am using the current version v0.8.1489 of the Rive app for Mac on macOS Sonoma 14.5.

Unfortunately, the + and - keys for zooming have no function here.

(Only F for zoom to fit and cmd+0 for zoom to 100 perform the expected actions.)

Unfortunately, this has made it impossible to work efficiently in the app, which is why I now use Rive in the browser again, where zooming works using the + and - keys.

3 replies
18d ago

RIve animation that works in editor freezes on share

I have an animation that works fine in the editor, and up until yesterday, worked perfectly with the share links.

But now the animations suddenly stops in different moments.

Strangely, when changing viewport size(or turning the phone on mobile) the next state is showed. I am using Chrome on Desktop and iOS on mobile.

Please help me solve this problem, since this project is a commission. Thanks.

Here you can see a video of the problem:

6 replies
R
19d ago

Application crashes (EXC_CRASH (SIGABRT)) when displaying an animation with state machine in SwiftUI

Application crashes (EXC_CRASH (SIGABRT)) when displaying an animation with state machine in SwiftUI.

Some of our users have reported an immediate application crash when a Rive animation is displayed. Analysis of crash reports seem to indicate that this is caused by a call from the RiveRuntime framework, causing a NSInvalidArgumentException, see snippet below: (Full crash reports are available if needed)

  "exception" : {"codes":"0x0000000000000000, 0x0000000000000000","rawCodes":[0,0],"type":"EXC_CRASH","signal":"SIGABRT"},
  "termination" : {"flags":0,"code":6,"namespace":"SIGNAL","indicator":"Abort trap: 6","byProc":"Application","byPid":1045},
  "asi" : {"libsystem_c.dylib":["abort() called"]},
  "exceptionReason" : {"arguments":["-[__NSArrayM insertObject:atIndex:]"],"format_string":"*** %s: object cannot be nil","name":"NSInvalidArgumentException","type":"objc-exception","composed_message":"*** -[__NSArrayM insertObject:atIndex:]: object cannot be nil","class":"NSException"},
  "extMods" : {"caller":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"system":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"targeted":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"warnings":0},
  "lastExceptionBacktrace" : [
{"imageOffset":978358,"symbol":"__exceptionPreprocess","symbolLocation":226,"imageIndex":9},
{"imageOffset":81565,"symbol":"objc_exception_throw","symbolLocation":48,"imageIndex":7},
{"imageOffset":123841,"symbol":"-[__NSArrayM insertObject:atIndex:]","symbolLocation":1762,"imageIndex":9},
{"imageOffset":35776,"symbol":"-[RiveStateMachineInstance stateChanges]","symbolLocation":178,"imageIndex":1},

We're new to Rive so we might be doing something wrong, still the issue doesn't happen on our development machines.

Below you can see a stripped down version of our code:

struct ContentView: View {
    @EnvironmentObject var appState: AppState
    
    let property1 = false
    
    let min = 1.0
    let max = 3.0
    @State private var property2 = 1.0
    
    @State var timer = Timer.publish(every: 60,  tolerance: 1, on: .main, in: .common).autoconnect()
    
    @StateObject var riveViewModel = RiveViewModel(
        fileName: "animation",
        stateMachineName: "Default State Machine"
    )
    
    var body: some View {
        VStack {
            if appState.showAnimation {
                riveViewModel.view()
                    .backgroundStyle(.clear)
            }
        }
        .onAppear(perform: {
            riveViewModel.setInput("Property1", value: property1)
            riveViewModel.setInput("Property2", value: property2)
            riveViewModel.setInput("Property3", value: false)
        })
        .onHover { hover in
            if (hover) {
                riveViewModel.setInput("Property3", value: true)
                property2 = min
            }
            else {
                riveViewModel.setInput("Property3", value: false)
            }
        }
        .onReceive(timer) { value in
            if property2 < max {
                property2 += 1
            }
        }
        .onChange(of: property2) {
            riveViewModel.setInput("Property2", value: property2)
        }
    }
}
  • Devices: Mac14,2, Mac15,6, MacBookPro18,3, MacBookPro15,2

  • OS Version: macOS 14.5 (23F79)

  • RiveRuntime: 5.13.2

Unfortunately, we cannot reproduce this issue ourselves, which makes it hard to troubleshoot. However, several users have experienced this unexpected behavior. We are open to test/validate any suggestions with our testers.

FYI we also posted this issue in the GitHub repo: https://github.com/rive-app/rive-ios/issues/330

6 replies