t
14d ago

Rive projects behaving differently when published to the "community" compared to in the rive editor app.

  1. When a listener event is triggered (Listener 1), it seems that the boolean input state is not saved or changed on web, whereas in the rive editor, the boolean input state is registered and updated-
    specifically the boolean input, "parent ring-state".

  2. Google Chrome, Windows 11, RIVE Beta 0.8.1489

  3. Sorry I do not have Rive Pro

bell_anim.riv
820 KB
7 replies
t
14d ago

Hi , Thank you for sharing this. This may be some problem with the runtime. Have you tested if it works with the Embed link?

t
(edited) 13d ago

Hi!, I have not tested with the embedded link- are you referring to the share option here? If so I don't think I have access to it as it is a pro feature.

Regarding the runtime, is that the release version of the rive editor app? "0.8.1489"
If so should I be testing older versions of the app? (not sure if that's possible)

13d ago

No problem. We have been able to reproduce the problem and it will be resolved soon.

t
13d ago

Great Thank you!

13d ago

The problem is fixed. Should work now.

t
(edited) 10d ago

I hate to bring this up but the same issue occurs when I download the .riv (from beta 0.8.1515) and implement on the web with react. However the rive community post works perfectly.

8d ago

Make sure you have the latest version of the runtine. If you still have the problem with this, it would be good if you shared a link so we can check it.